using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\P{L}";
string substitution = @"";
string input = @"Test123éËà-ŞŨğБла通用";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}