const regex = new RegExp('\\P{L}', 'gm')
const str = `Test123éËà-ŞŨğБла通用`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);