using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\p{P}\p{S}]+";
string substitution = @"_";
string input = @"Test123éËà-.....()[/////]ŞŨğБла通用!.~12";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}