package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\p{P}\p{S}]+`)
var str = `Test123éËà-.....()[/////]ŞŨğБла通用!.~12`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}