use strict;
my $str = 'Test123éËà-.....()[/////]ŞŨğБла通用!.~12';
my $regex = qr`[\p{P}\p{S}]+`mp;
my $subst = '_';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";