$re = '`[\p{P}\p{S}]+`m';
$str = 'Test123éËà-.....()[/////]ŞŨğБла通用!.~12';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;