using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Case_Status__c"":""(?<status>.*?)"".*?""Emergency_Outage_Case__c"":(?<emgcase>.*?)}]}";
string input = @"{""searchRecords"":[{""attributes"":{""type"":""Case"",""url"":""/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ""},""Id"":""500e000000DmsKDAAZ"",""Case_Status__c"":""Open"",""Emergency_Outage_Case__c"":true}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}