import Foundation
let pattern = #""Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"searchRecords":[{"attributes":{"type":"Case","url":"/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ"},"Id":"500e000000DmsKDAAZ","Case_Status__c":"Open","Emergency_Outage_Case__c":true}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)