package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}`)
var str = `{"searchRecords":[{"attributes":{"type":"Case","url":"/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ"},"Id":"500e000000DmsKDAAZ","Case_Status__c":"Open","Emergency_Outage_Case__c":true}]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}