#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?![,0-9]{14})\d{1,3}(?:,\d{3})*(?:\.\d{1,2})?|(?![.0-9]{14})\d{1,3}(?:\.\d{3})*(?:\,\d{1,2})?)$"
Local $sString = "123,456.00" & @CRLF & _
"123.456,00" & @CRLF & _
"" & @CRLF & _
"123,456,789.00" & @CRLF & _
"123.456.789,00" & @CRLF & _
"" & @CRLF & _
"123.456.789,0" & @CRLF & _
"123,456,781,123.00" & @CRLF & _
"123.456.789.123,00" & @CRLF & _
"" & @CRLF & _
"234,567,890.89" & @CRLF & _
"1,234,567,890.89" & @CRLF & _
"1,234,567,890" & @CRLF & _
"1,234,567,890.89"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")