import re
regex = re.compile(r"^(?:(?![,0-9]{14})\d{1,3}(?:,\d{3})*(?:\.\d{1,2})?|(?![.0-9]{14})\d{1,3}(?:\.\d{3})*(?:\,\d{1,2})?)$", flags=re.MULTILINE)
test_str = ("123,456.00\n"
"123.456,00\n\n"
"123,456,789.00\n"
"123.456.789,00\n\n"
"123.456.789,0\n"
"123,456,781,123.00\n"
"123.456.789.123,00\n\n"
"234,567,890.89\n"
"1,234,567,890.89\n"
"1,234,567,890\n"
"1,234,567,890.89")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")