using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?![,0-9]{14})\d{1,3}(?:,\d{3})*(?:\.\d{1,2})?|(?![.0-9]{14})\d{1,3}(?:\.\d{3})*(?:\,\d{1,2})?)$";
string input = @"123,456.00
123.456,00
123,456,789.00
123.456.789,00
123.456.789,0
123,456,781,123.00
123.456.789.123,00
234,567,890.89
1,234,567,890.89
1,234,567,890
1,234,567,890.89";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}