re = /^(?:(?![,0-9]{14})\d{1,3}(?:,\d{3})*(?:\.\d{1,2})?|(?![.0-9]{14})\d{1,3}(?:\.\d{3})*(?:\,\d{1,2})?)$/m
str = '123,456.00
123.456,00
123,456,789.00
123.456.789,00
123.456.789,0
123,456,781,123.00
123.456.789.123,00
234,567,890.89
1,234,567,890.89
1,234,567,890
1,234,567,890.89'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end