package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\S*[a-z].+[a-z0-9]`)
var str = `.. -- Água, 1234 ...
- -- https://www.example.com/page.html *****`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}