$re = '/(?i)\S*[a-z].+[a-z0-9]/m';
$str = '.. -- Água, 1234 ...
- -- https://www.example.com/page.html *****';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);