$re = '/^(?:[ab]|ab)(.)(?:(?!\1).)+\1$/m';
$str = 'It is pattern against free delimiter
ab some-word
a some-word
b|some-word|
ab#some-word#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);