re = /^(?:[ab]|ab)(.)(?:(?!\1).)+\1$/m
str = 'It is pattern against free delimiter
ab some-word
a some-word
b|some-word|
ab#some-word#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end