import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span>\n"
+ " [^<]*+\n"
+ " (?>\n"
+ " [^<]+\n"
+ " | (?!<span>|</span>).\n"
+ " )*+\n"
+ "</span>";
final String string = "Начало.\n"
+ "<spar>ошибка</spar>\n"
+ "<span><b>правильно</b></span>\n"
+ "ошибка\n"
+ "<span>правильно <i><span>правильно</span></i> правильно</span>.\n"
+ "ошибка\n"
+ "<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.\n"
+ "ошибка\n"
+ "<span><spar>правильно</spar></span>\n"
+ "ошибка\n"
+ "<span></span>\n"
+ "ошибка\n"
+ "<span><span></span></span>\n"
+ "ошибка\n"
+ "<span>ошибка<span>ошибка<span>правильно</span>\n"
+ "<span>ошибка<span>\n"
+ "Конец.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}