import re
regex = re.compile(r"""
<span>
[^<]*+
(?>
[^<]+
| (?!<span>|</span>).
)*+
</span>
""", flags=re.DOTALL | re.VERBOSE | re.IGNORECASE)
test_str = ("Начало.\n"
"<spar>ошибка</spar>\n"
"<span><b>правильно</b></span>\n"
"ошибка\n"
"<span>правильно <i><span>правильно</span></i> правильно</span>.\n"
"ошибка\n"
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.\n"
"ошибка\n"
"<span><spar>правильно</spar></span>\n"
"ошибка\n"
"<span></span>\n"
"ошибка\n"
"<span><span></span></span>\n"
"ошибка\n"
"<span>ошибка<span>ошибка<span>правильно</span>\n"
"<span>ошибка<span>\n"
"Конец.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")