re = /<span>
[^<]*+
(?>
[^<]+
| (?!<span>|<\/span>).
)*+
<\/span>/xi
str = 'Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end