// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sxi)<span>
[^<]*+
(?>
[^<]+
| (?!<span>|</span>).
)*+
</span>").unwrap();
let string = "Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}