using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+=\s*({(?:[^}{]++|(?-1))*})";
string input = @"1111=
{
name=""NY""
owner=""USA""
controller=""USA""
core=""USA""
garrison=100.000
artisans=
{
id=172054
size=40505
american=protestant
money=5035.95938
}
clerks=
{
id=17209
size=1988
nahua=catholic
money=0.00000
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}