$re = '/\d+=\s*({(?:[^}{]++|(?-1))*})/';
$str = '1111=
{
name="NY"
owner="USA"
controller="USA"
core="USA"
garrison=100.000
artisans=
{
id=172054
size=40505
american=protestant
money=5035.95938
}
clerks=
{
id=17209
size=1988
nahua=catholic
money=0.00000
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);