import Foundation
let pattern = #"\d+=\s*({(?:[^}{]++|(?-1))*})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1111=
{
name="NY"
owner="USA"
controller="USA"
core="USA"
garrison=100.000
artisans=
{
id=172054
size=40505
american=protestant
money=5035.95938
}
clerks=
{
id=17209
size=1988
nahua=catholic
money=0.00000
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)