// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+=\s*({(?:[^}{]++|(?-1))*})").unwrap();
let string = "1111=
{
name=\"NY\"
owner=\"USA\"
controller=\"USA\"
core=\"USA\"
garrison=100.000
artisans=
{
id=172054
size=40505
american=protestant
money=5035.95938
}
clerks=
{
id=17209
size=1988
nahua=catholic
money=0.00000
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}