const regex = /(?<=((?<=[\s,.:;"']|^)["']))(?:(?=(\\?))\2.)*?(?=\1)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=((?<=[\\s,.:;"\']|^)["\']))(?:(?=(\\\\?))\\2.)*?(?=\\1)', 'gmu')
const str = `Hello world "This is a test"
"This is also an NL test"
'And this has an escaped quote don\\'t in it ' Blue Boy
"This has a single quote ' but doesn\\' end the quote as it started with double quotes"
" Lorem ipsum dolor\\" sit 'amet' "
"你好" "こんにちは" "Привет" "हैलो"
"Foo Bar" "Another Value" "HELLO WORLD"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}