$re = '/(?<=((?<=[\s,.:;"\']|^)["\']))(?:(?=(\\\\?))\2.)*?(?=\1)/mu';
$str = 'Hello world "This is a test"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes"
" Lorem ipsum dolor\\" sit \'amet\' "
"你好" "こんにちは" "Привет" "हैलो"
"Foo Bar" "Another Value" "HELLO WORLD"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);