import re
regex = re.compile(r"(?<=((?<=[\s,.:;\"']|^)[\"']))(?:(?=(\\?))\2.)*?(?=\1)", flags=re.MULTILINE | re.UNICODE)
test_str = ("Hello world \"This is a test\"\n"
"\"This is also an NL test\"\n"
"'And this has an escaped quote don\\'t in it ' Blue Boy\n"
"\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\"\n\n"
"\" Lorem ipsum dolor\\\" sit 'amet' \"\n\n"
"\"你好\" \"こんにちは\" \"Привет\" \"हैलो\"\n"
"\"Foo Bar\" \"Another Value\" \"HELLO WORLD\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")