import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:(,]*)\\b";
final String string = "Boston (Boston University, Boston College, Bos...\n"
+ "Bridgewater (Bridgewater State College)[2]\n"
+ "Cambridge (Harvard University, Massachusetts I...\n"
+ "Chestnut Hill (Boston College)\n"
+ "The Colleges of Worcester Consortium:\n"
+ "Dudley (Nichols College)\n"
+ "Faribault, South Central College\n"
+ "Mankato (Minnesota State University, Mankato),...\n"
+ "Marshall (Southwest Minnesota State University...\n"
+ "Moorhead (Minnesota State University, Moorhead...\n"
+ "Morris (University of Minnesota Morris)[2]\n"
+ "Northfield (Carleton College, St. Olaf College...\n"
+ "North Mankato, South Central College\n"
+ "St. Cloud (St. Cloud State University, The Col...\n"
+ "St. Joseph (College of Saint Benedict)[2]\n"
+ "St. Peter (Gustavus Adolphus College)[2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}