$re = '/^([^:(,]*)\b/m';
$str = 'Boston (Boston University, Boston College, Bos...
Bridgewater (Bridgewater State College)[2]
Cambridge (Harvard University, Massachusetts I...
Chestnut Hill (Boston College)
The Colleges of Worcester Consortium:
Dudley (Nichols College)
Faribault, South Central College
Mankato (Minnesota State University, Mankato),...
Marshall (Southwest Minnesota State University...
Moorhead (Minnesota State University, Moorhead...
Morris (University of Minnesota Morris)[2]
Northfield (Carleton College, St. Olaf College...
North Mankato, South Central College
St. Cloud (St. Cloud State University, The Col...
St. Joseph (College of Saint Benedict)[2]
St. Peter (Gustavus Adolphus College)[2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);