# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^:(,]*)\b"
test_str = ("Boston (Boston University, Boston College, Bos...\n"
"Bridgewater (Bridgewater State College)[2]\n"
"Cambridge (Harvard University, Massachusetts I...\n"
"Chestnut Hill (Boston College)\n"
"The Colleges of Worcester Consortium:\n"
"Dudley (Nichols College)\n"
"Faribault, South Central College\n"
"Mankato (Minnesota State University, Mankato),...\n"
"Marshall (Southwest Minnesota State University...\n"
"Moorhead (Minnesota State University, Moorhead...\n"
"Morris (University of Minnesota Morris)[2]\n"
"Northfield (Carleton College, St. Olaf College...\n"
"North Mankato, South Central College\n"
"St. Cloud (St. Cloud State University, The Col...\n"
"St. Joseph (College of Saint Benedict)[2]\n"
"St. Peter (Gustavus Adolphus College)[2]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.