// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^:(,]*)\b").unwrap();
let string = "Boston (Boston University, Boston College, Bos...
Bridgewater (Bridgewater State College)[2]
Cambridge (Harvard University, Massachusetts I...
Chestnut Hill (Boston College)
The Colleges of Worcester Consortium:
Dudley (Nichols College)
Faribault, South Central College
Mankato (Minnesota State University, Mankato),...
Marshall (Southwest Minnesota State University...
Moorhead (Minnesota State University, Moorhead...
Morris (University of Minnesota Morris)[2]
Northfield (Carleton College, St. Olaf College...
North Mankato, South Central College
St. Cloud (St. Cloud State University, The Col...
St. Joseph (College of Saint Benedict)[2]
St. Peter (Gustavus Adolphus College)[2]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}