#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)56K"
Local $sString = "Bytes: 256K " & @CRLF & _
"Bytes256K " & @CRLF & _
"Bytes8356K " & @CRLF & _
"Bytes: 756K " & @CRLF & _
"Bytes: 56K " & @CRLF & _
"Bytes56K "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")