$re = '/(?<!\d)56K/m';
$str = 'Bytes: 256K
Bytes256K
Bytes8356K
Bytes: 756K
Bytes: 56K
Bytes56K ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);