re = /(?<!\d)56K/m
str = 'Bytes: 256K
Bytes256K
Bytes8356K
Bytes: 756K
Bytes: 56K
Bytes56K '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end