const regex = /(?<!\d)56K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)56K', 'gm')
const str = `Bytes: 256K
Bytes256K
Bytes8356K
Bytes: 756K
Bytes: 56K
Bytes56K `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}