using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\W|^)(alineas|alinea|alis\.?|ali\.?) (?:([a-z])|\""([a-z])\"")(?:\W|$)";
string input = @"alinea a,
alinea ""a"",
ali. ""a"",
ali ""a"",
ali. a,
ali. ""a"",
ali. a"",
ali a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}