const regex = new RegExp('(?:\\W|^)(alineas|alinea|alis\\.?|ali\\.?) (?:([a-z])|\\"([a-z])\\")(?:\\W|$)', 'gm')
const str = `alinea a,
alinea "a",
ali. "a",
ali "a",
ali. a,
ali. "a",
ali. a",
ali a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}