#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)(?:\r?\n|$)"
Local $sString = "line1" & @CRLF & _
"line2" & @CRLF & _
"line3"
Local $sSubst = "$1\n$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)