use strict;
my $str = 'line1
line2
line3';
my $regex = qr/^(.*)(?:\r?\n|$)/mp;
my $subst = '$1\\n$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";