re = /^(.*)(?:\r?\n|$)/m
str = 'line1
line2
line3'
subst = '$1\\n$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result