$re = '/^(.*)(?:\r?\n|$)/m';
$str = 'line1
line2
line3';
$subst = "$1\n$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;