$re = '/[\t ]+/';
$str = 'Hello World!
Tab and space inside.
trailing tab
Nothing special.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;