import re
regex = re.compile(r"[\t ]+")
test_str = ("Hello World!\n"
"Tab and space inside.\n"
"trailing tab \n"
"Nothing special.")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)