# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\w{30,1000})?\b//gm;t' <<< "http://www.youtube.com/watch?v=qsXHcwe3krw
http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg
enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks
"