import re
regex = re.compile(r'(\b\w{30,1000})?\b', flags=re.MULTILINE)
test_str = ("http://www.youtube.com/watch?v=qsXHcwe3krw\n"
"http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg\n"
"enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)