#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b\w{30,1000})?\b"
Local $sString = "http://www.youtube.com/watch?v=qsXHcwe3krw" & @CRLF & _
"http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg" & @CRLF & _
"enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)