const regex = /select\s.*\sfrom\s(\S+)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('select\\s.*\\sfrom\\s(\\S+)\\s*', 'gm')
const str = `select Count_Big(*) from dbo.Orders orderby date desc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}