$re = '/select\s.*\sfrom\s(\S+)\s*/m';
$str = 'select Count_Big(*) from dbo.Orders orderby date desc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);