import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(\\w+)[= ](?|\"((?:[^\"\\\\]|\\\\.)*)\"|(\\d+))";
final String string = "-Parameter1=1234 -Parameter2=38518 -param3 \"Test \\\"escaped\\\"\" -param4 10 -param5 0 -param6 \"TT\" -param7 \"Seven\" -param8 \"secret\" \"-SuperParam9=4857?--SuperParam10=123\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}